安装vim8并添加python3支持

之前安装vim8支持python3时,捣鼓了许久才成功,现记录一下以便后面使用查看。

yum安装python3

安装epel

1
sudo yum install epel-release

安装python3

1
sudo yum install python36 python36-devel

安装后使用命令python36,如能进入python3.6的命令界面,说明已安装成功

编译安装vim并添加python3支持

安装依赖

1
sudo yum install ncurses-devel

删除原来的vim

1
sudo yum remove vim

从git下载最新的vim并安装

1
2
3
4
5
sudo git clone https://github.com/vim/vim.git
cd vim/src
sudo ./configure --with-features=huge --enable-multibyte --enable-rubyinterp=yes --enable-python3interp=yes --prefix=/usr/local/vim8 --disable-selinux --enable-cscope --with-python3-command=python3.6
sudo make
sudo make install

要注意的是,configure必须加上–enable-python3interp与–with-python3-command,同时–with-python3-command后的值是你本地能运行python3的命令,我本机用python36或python3.6都能进入python3,所以这里是python3.6,并不一定适用于其它环境。

创建软链接

1
sudo ln -s /usr/local/vim8/bin/vim /usr/bin/vim

执行vim –version,如果能看到+python3,说明就已经成功。
成功界面


- - END - -


腾讯云
0%